More testing, issue with column sorting. (App-001)

Column sorting didn't include the selected paramter for browser, os, etc, as parameter wasn't passed on, so added:

    <th><%= link_to 'Year', :sort_column => 'by_year', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
    <th><%= link_to 'Month', :sort_column => 'by_month', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
    <th><%= link_to '%', :sort_column => 'percentage', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
	<th><%= link_to 'Browser', :sort_column => 'browser', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
    <th><%= link_to 'OS', :sort_column => 'os', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
    <th><%= link_to 'Colors', :sort_column => 'color_depth', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %></th>
    <th><%= link_to 'Res', :sort_column => 'resolution', :resolution => params[:resolution], :color => params[:color], :browser => params[:browser], :os_source => params[:os_source] %>.</th>

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s